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Chapter 1 Introduction

This supplement to the ElectricImage™ documentation covers the 
enhancements and new features for Version 2.7.5 of the ElectricImage™ 
Animation System and ElectricImage Broadcast.
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Chapter 2 Project Window Enhancements

The Project Window contains a complete animation overview of your 
project. Original remarks for the Project Window can be found in the 
ElectricImage™ Reference Manual, Chapter 8. Several enhancements 
have been added for this version.
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Chapter 2: Project Window Enhancements

               
View By Hierarchy (2-8) Color Label (2-7)

 Time Thumb Display (2-5) Surface Editor (2-4)

Figure 2.1   Project Window Overview

Functional Changes
There are two minor changes to the functionality of the Project Window 
of which to be aware.

When you change the visible and locking options of your objects in the 
Project Window, this does not automatically deselect them anymore.

You no longer have to hit the enter key to make the edit bar at the top of 
the project window active. Just click the mouse once in the edit box to 
make it active.
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Frame Index Start

       
Frame Index Start
If you prefer that the first frame of your animation to be numbered 1 
instead of 0, you can now change this in the Drawing Preference 
Window. All you have to do is set this parameter to 1. 

New preference

Figure 2.2   Drawing Preferences window highlighting Frame Index Start 
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Chapter 2: Project Window Enhancements

       
Surface Editor Button
An additional button has been placed in the toolbar and at the top of the 
project window that immediately calls up the Surface Editor. When called 
up by this button, the All Keys and Current Time buttons will set the 
material for ALL selected groups currently highlighted in the project 
window.

�
For detailed information of the Surface Editor see Chapter 8, in the 

�
ElectricImage Reference Manual.
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Time Thumb Display

        
Time Thumb Display
The project window now supports the display of the Time Thumb in 
Seconds, Timecode or Frames. Select one of the three modes in the Time 
Thumb Display pulldown.

 

Figure 2.3   Time Thumb Display pulldown

To go to a particular second, time code or frame of your animation, just 
type in the value in the edit bar. 

Figure 2.4   Project Window Time Mode
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If the project is in interlace mode, you may enter interlace markers (a, b) 
as well as the frame number.

Figure 2.5   Project Window Time mode with Interlace
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Color Labels

      
Color Labels
Groups or objects may now be given color labels (the color is applied to 
the name (text) of the group as displayed in the Project Window). These 
can be used to maintain a custom hierarchy and to select groups based on 
their labels

The Edit... selection is used to change the name assigned to each color in 
the pulldown menu.

Figure 2.6   Label Pulldown
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View By Hierarchy
The Project Window now supports four different ways for ordering the 
objects in the list view.

Figure 2.7   Project View By Hierarchy Pulldown

Flat

Flat lists objects by seniority. The camera first, light second and all 
objects, etc. in order of when they were added to the project — first 
come, first list.

�
Holding down the option and command keys while clicking on the visibility 
or lock boxes in the project window will set the rest of the same type of 

�
objects down the list.

Hierarchy

Hierarchy also lists objects by seniority. However, linked objects appear in 
the parent/child relationship.

�
Holding down the option and command keys while clicking on the visibility 
or lock boxes in the project window will set the siblings and offspring of the 

�
object.
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View By Hierarchy
By Name

By Name lists the objects alphabetically.

�
Holding down the option and command keys while clicking on the visibility 
or lock boxes in the project window will set the rest of the same labeled 

�
objects down the list.

By Label

By Label lists the objects according to the color labels you have assigned 
them.

�
Holding down the option and command keys while clicking on the visibility 
or lock boxes in the project window will set the rest of the same labeled 

�
objects down the list.
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Chapter 2: Project Window Enhancements
Multiple Keyframe Control
Version 2.7.5 supports selecting, dragging and scaling multiple keyframes 
of one or more objects when the Project Window is set to Time View. Or, 
you can select and drag the entire animation track of a single object.

Selecting and Dragging Multiple Keyframes

Keyframes may be selected by dragging a marquee around a group of 
keyframes or by holding down the shift key and clicking the individual 
keyframes you wish to modify using the mouse. Keyframes, once 
selected, are shown in dark blue. Dragging one of the selected keyframes 
left or right will move all of them.

Figure 2.8    Dragging rectangle to select keyframes
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Multiple Keyframe Control
Selecting and Dragging the Entire Animation Track

The entire animated track may be moved left and right by grabbing the 
violet bar in between two keyframes and dragging.

Figure 2.9   Dragging an animation track

Keyframe Dragging With Scale

To create a scaling region, hold down the control key and drag in the 
time line as shown below. The scaling region you have selected will be 
illustrated by the violet selected area as seen below.

Figure 2.10    Selection of Scaling region by control-dragging the time bar

Once you have the scale region selected (Figure 2.11), dragging keys 
while holding down the control key will scale keys inside the scale 
region. Keys outside the scale region will be dragged until they enter the 
scale region where they will be scaled (if the control key is held down 
while dragging).
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Figure 2.11   Selection of Keyframes and Scaling Region

If you initially drag from the left side of the scale region, the key times are 
scaled toward the right end of the scale region(Figure 2.12). If you 
initially drag from the right side of the scale region, the key times are 
scaled toward the left end of the scale region(Figure 2.13). If you initially 
drag from the inside of the scale region, the key times are scaled either 
way depending on the initial mouse movement (left is towards the start, 
right is towards the end)

Figure 2.12   Control-Dragging from Left to Right

Figure 2.13   Control-Dragging from Right to Left
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Time Palette
Duplicating Multiple Keyframes

To duplicate keyframes, select the desired keyframes, then option-drag. 
New keyframes will be created.

Time Palette
This new palette, available from the Windows pulldown menu (or as a 
shortcut using command-minus), allows you to change the project time 
without having to keep the Project Window open. The Time Palette also 
displays the range-of-frames start and stop times with two small flags. 
These flags may be dragged in the palette to change the range-of-frames. 
The time display can be changed to frames or timecode by holding down 
the option-key and selecting the time thumb.

Range of frame markers Time Thumb Resize Control

Figure 2.14   Time Palette

�
Command - Arrow keys moves the global time line by one frame. Command 

�
- Shift -Arrow keys moves the global time line ten frames.
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Chapter 3 World View Windows

The World View Windows are your workspace in ElectricImage™. You 
can view and make changes from top, side and front views. Original 
documentation for the World View windows can be found in the 
ElectricImage™ Reference Manual, Chapter 6.

�
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Chapter 3: World View Windows
Previews
The following enhancements have been made to the preview system in 
the World Views: 

• Animation previews are now supported in World View windows.

• Previews can show or suppress display or preview rendering of 
effectors and paths.

• Dragging the thumb back and forth during an animation preview 
will now cause the expected “jog” behavior.

Figure 3.1   World View Window

Preview Button
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Zooming
Zooming
• You can Scale the window view content to match the window size by 

holding down the option key while you hit the Grow or Zoom 
buttons in the World View Window

• Option-Control-Zoom fits the window into the view of selected 
objects only

Figure 3.2   World View Window

Zoom Buttons
Grow Button
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Chapter 4 Multiple Cameras

The Camera View window shows you what the your project looks like 
from the camera’s point of view for the selected frame. Original 
documentation for the Camera View window can be found in the 
ElectricImage™ Reference Manual, Chapter 7. Original documentation 
for the Camera Info Window can be found in the ElectricImage™ 
Reference Manual, Chapter 10.

�
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Chapter 4: Multiple Cameras
Changes to the Camera View Window
• Previews can show or suppress display or preview rendering of 

effectors, groups, lights, cameras, and paths

• Dragging the thumb back and forth during a preview will now cause 
the expected “jog” behavior.

• Objects can now be selected and moved in this window. The 
selection state of objects is also displayed.

• Move controls inside the camera view window for cameras and lights 
(when the Camera View has been set to look down the cone of a 
spotlight).

The Camera View move controls are:

None –This is the Default condition and allows no control in the 
camera view.

Orbit –Moves the camera about its reference point.

The modifier key for this operation is: Command-Spacebar

Pan –Moves the camera reference point up/down and left/right.

The modifier key for this operation is: Option-Spacebar

Dolly –Moves the camera toward/away from its reference point.

The modifier key for this operation is: Control-Spacebar

Track –Moves the camera and its reference point up/down and 
left/right.

The modifier key for this operation is: Spacebar
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Changes to the Camera View Window
Zoom –Interactively changes the camera’s focal length

The modifier key for this operation is: Shift-Spacebar

�

�
Note: Zoom does not apply to light sources.

�
A velocity curve for Camera Focal Length has been added to the Camera’s 
velocity graph window. Original documentation for the Camera Velocity 

�
Window is available in the ElectricImage reference book page 17-9.
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Changes to the Camera Info Window

Background Images

Control of background images has been moved to this window. In this 
way, each camera in the scene can have a different background image. 
The background image which is rendered into your project is dependent 
upon which camera is chosen for the rendering.

Figure 4.1   Camera Info Window
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Changes to the Camera Info Window
Stereoscopic Rendering

Stereoscopic rendering creates a “left eye” and “right eye” rendering for 
each frame in an animation. Finished still frames or animation files will 
have either (L) or (R) placed at the end of their names.

Stereo Checkbox Enables stereo rendering system.

Stereo Separation Separation in world units between the two cameras

Stereo Convergence Distance in world units between the face of the cameras and the point 
where the view of the cameras converge.

Converge Gives three choices in determining how the convergence point is 
determined. By Channel allows the Stereo Convergence value to be 
animated. By Reference uses the camera reference to set the convergence 
point. In Infinity causes no convergence to take place (the two cameras 
are parallel to each other).

Render Four options for controlling the output rendering. Normal causes a 
non-stereo rendering to take place. Left Only causes only the left camera 
to be rendered at each frame. Right Only causes only the right camera to 
be rendered at each frame. Left/Right causes both cameras to be rendered 
at each frame. In this case, two separate still renderings or animation files 
will be created.
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Multiple Cameras
Extra cameras can be added to the project using the File Menu 
>Add>Type>Camera command from the File pulldown menu, or by 
duplicating an existing camera. By holding down the option-key in the 
title bar of the Camera View Window, you can change the view to any 
existing camera. Only the camera currently viewed in the Camera View 
Window will be rendered. It is not possible to animate a switch from one 
camera to another.

Figure 4.2   Option-selecting in title bar of camera view window
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Multiprocessing Camera
Multiprocessing Camera

The multiprocessor (MP) version of Camera has been shipped with 
version 2.7.5. It is contained in a folder, MP Camera, in the ElectricImage 
folder on the CD. This version of Camera supports the Apple MP API and 
will run on any computer or plug-in card that supports this API.

MP Camera works by splitting up a single frame of an animation into 
segments (threads) and sending each one to a different processor on a 
single computer. It does not support rendering a separate frame on each 
of the processors in a single computer.

MP Camera will use all processors present. This means that it will also run 
on a single processor computer. It is important to remember that 
different versions of Camera may yield slightly different imagery. If you 
plan to render on multiple computers that includes at least one MP, use 
the MP camera on all those computers - even if some of them only have a 
single processor. This will insure continuity between the segments of an 
animation rendered on the different computers.

The Apple MP API does not support symmetrical multiprocessing (SMP). 
This means that the individual threads cannot gain access to the hard 
drive. Therefore, Camera must load all texture maps, shadow buffers, 
reflection maps and 3D geometry into RAM before rendering can begin. 
Thus, it may require considerably more memory to render using the MP 
Camera.

The performance that you see when using the MP Camera will vary 
considerably based on your project files. Items that take the longest time 
to render, Smoke for instance, will get the largest performance gain. But a 
100,000 polygon model with a single light source may see little or no 
improvement. 

The large variation in performance is due to the asymmetrical nature of 
Apple’s multiprocessing API. Electric Image does not see any way to make 
additional improvements to MP Camera until the Apple O/S supports 
SMP. We are eager to create versions of our software that can handle 
tremendous numbers of polygons and print-resolution texture maps. In 
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the future, we may decide to sacrifice MP support under the Mac O/S to 
enable these important features.
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Chapter 5 Select Menu Additions

The Select Menu was added in Version 2.5, replacing the Model List 
menu. It allows you to select objects in the World View and Project 
windows. Original remarks for the Select menu can be found in the 
ElectricImage™ Version 2.5 Supplement, Chapter 10. 

�
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Chapter 5: Select Menu Additions
Select Menu Additions
The Select Menu has been reorganized for easier use and one new 
selection type has been added, By Label.

Figure 5.1   The Select Menu (at left) and the Select Menu with Option Key (at right)
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Select Menu Additions
.

Command Sub-Command Description

All Selects all unlocked objects (same as previous Edit menu 
command).

None Deselects all selected objects.

Inverse Deselects all selected objects while selecting all other objects 
that are not locked.

Find Opens a dialog box to enter a search string (same as previous 
Edit menu command). Wildcards may now be used to 
control the search. Selects the first object in the project 
window list that matches the search string.

Find Again Selects next object matching the search string previously 
entered with the Find command (same as previous Edit 
menu commands).

Find All… Similar to the Find command except that all objects 
matching the search strings are selected.

By Attribute –

Visible Selects all objects with visibility check boxes on

Locked Selects all objects with lock check boxes on.

Hidden Selects all objects hidden in the Project window.

By Type –

Camera Selects the Camera.

Lights Selects all lights.

Groups Selects all groups.

Effectors Selects all effectors. 

Sounds Selects sound tracks.

Smoke Selects smoke objects

By Hierarchy –

Parent of Selected Selects the immediate parent of the currently selected 
object.
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Chapter 5: Select Menu Additions
Choosing the Select menu while the Option key is held down reveals several commands, listed in the 
table below:

.

Children of Selected Selects the immediate children of the currently selected 
object.

By Label Gives you the ability to select objects based on the color 
labels that you assign your objects.

Edit… Allows you to change the names assigned to the different 
colors.

By Model Selects objects based on the names of the models that have 
been added to the project.
Note: the name of the model file may not be the same as the 
group name in the project window.

Command Sub-Command Description

Command Sub-Command Description

All + Locked Selects every object in the project.

By Hierarchy –

Ancestors of 
Selected

Selects all parents up the hierarchy.

Offspring of 
Selected

Selects all children down the hierarchy.
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Chapter 6 File Menu Changes

The add and save submenus in the File Menu have been updated for 
easier use and added functionality. Original documentation for the File 
Menu can be found in the ElectricImage™ Reference Manual, Chapter 1.

�
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Chapter 6: File Menu Changes
File Menu Changes
The File menus add and save > model commands have been reorganized 
for easier use. In addition, new commands for reloading the texture and 
color data from fact files (to override the information stored in the 
project file) has been included.

ElectricImage™ supports Truetype fonts and Postscript Type 1 fonts.

Command Sub-Command Description

Add > Model FACT Adds a new FACT model to the current project.

Add > Model Font Adds a Type 1 Postscript or TrueType font to the project.

Add > Model Other Brings up the model import window.

Add > Sound File Adds and AIFF or QuickTime sound file to the project.

Add > Sound Record Brings up the sound recording window.

Add > Type Camera Adds an additional camera to the project.

Add > Type Light Adds and additional light to the project.

Add > Type Smoke Adds a smoker to the project.

Add > Type Effector Adds an effector (empty group) to the project.

Add > Type Skeleton Adds a skeleton effector to the project.

Add >Motion Data.. - Imports a .bva, .bvh, or .obm motion file.

Export > Model FACT Saves the selected groups as a FACT file.

Export > Model Other Brings up the file export window to save the selected groups.

Export > Motion* BioVision Flat Saves out motion data from the selected groups in .bva 
format.

Export > Motion* BioVision 
Hierarchical

Saves out motion data from the selected groups in .bvh 
format.

Export > Motion* ElectricImage 
Motion

Saves out motion data from the selected groups in .obm 
format.
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File Menu Changes
*Motion Data Capture is a feature of the ElectricImage Animation System. 
This feature is available to ElectricImage Broadcast users as an option. 
Please contact sales or customer service for more information.

�
The Reload>Texture and Reload>Color commands are used to override the 
texture and color information in the project file with the original 
information stored in the FACT file for the selected group(s). This can be 
used to exchange texture and color data between separate projects or 

�
between several animators working on a single project.

-

Reload > Textures - Reloads the texture map placement data from a FACT file 
already loaded into the project. 

Reload > Colors - Reloads the color data from a FACT file already loaded into 
the project. 

Command Sub-Command Description
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Chapter 7 Model Import/Export

Two changes have been made to improve 3D model import and export. 
Models in Wavefront .OBJ format now have their normals read in and 
3DMF binary files can now be imported and exported.

�
Contents
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ElectricImage™ Version 2.7.5 Supplement 7-1



Chapter 7: Model Import/Export
Wavefront .OBJ Import
Normals are now read in for Wavefront .OBJ files. This makes a dramatic 
improvement in the shading quality for these models. If you are planning 
to purchase models from one of the many model vendors, your best bet is 
to choose models in this format, and to specify that normals are to be 
included with the model. Important: just because the format is .obj, does 
not mean normals are included.

3DMF
ElectricImage™ now imports and exports 3DMF binary models. We have 
tested this feature against a wide array of sample models, but please keep 
in mind that 3DMF is a relatively new format and is still subject to 
various interpretations. This means that models exported from another 
modeling or animation package may not always be imported with the 
same material or other characteristics intact.

A new preference dialog has been added to the model importation 
window.

Figure 7.1      3DMF import preferences
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3DMF
Override Tessellation
Settings

3DMF models can contain information describing how they should be 
tessellated (broken up into polygons). Checking this box causes 
ElectricImage™ to replace these built-in settings with either the Fixed or 
Adaptive settings below.

Fixed Tessellation This option breaks up the surfaces evenly by the number of steps shown 
in the U: and V: edit boxes. If the model does not seem to have enough 
polygons you can increase the mesh density by increasing the U: and V: 
parameters.

Adaptive
Tessellation

This option breaks up the surfaces according to curvature, providing 
more polygons in the curved portion of the surface. If the breakup seems 
to be creating too few polygons or if the object’s curvature does not seem 
to be preserved, make the value in the Tolerance edit box smaller.
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Chapter 8 Light Info Window Changes

The Light Info Window contains the permanent settings for a selected 
light or lights. Original comments for the Light Info window can be 
found in the ElectricImage™ Reference Manual, Chapter 11. Several 
enhancements have been developed.
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Smoke Objects
Smoke objects can now be used with Radial lights. Light Rays are not 
supported with Radial Lights. One use for this feature would be dust 
clouds in a desert or smoke rising out of a chimney.

Yaw, Pitch, and Roll

Figure 8.1   Light Info Window

Yaw, Pitch and Roll controls have been added for the Parallel, Radial, Spot 
and Tube lights. These controls operate the same as the Camera controls. 
Children attached to these lights will now inherit this information.
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Shadows
Shadows

Shadow Color

The Shadow Color button is used to add colors to the shadow buffer. In 
previous versions of ElectricImage™ shadows were always black (an 
absence of light).

This feature may be used to implement a transparent object casting a 
shadow of a similar hue, or contrasting shadows where an object casts an 
unrelated color onto a differently colored surface. It also allows better 
control for matching CameraMaps and textures upon which the shadow 
falls.

Shadow Buffer

A light’s shadow buffer now has a separate X and Y value. This allows 
non-square shadow buffers to be created. This feature is an important 
memory-saving device.

Shadows are calculated in pixels. The ‘Buffer Size’ is really a technical 
name for the number of pixels in the shadow map. The quality of the 
shadow is in direct relation to the size of the light’s cone and the buffer 
size, the size of receiving object relative to the buffer/cone.

As an example, consider a project containing a cube of 2 units resting on 
a ground plane of about 200 units. The project also contains a shadow 
casting light with the default buffer(1280) and cone size(45), and the 
light’s cone only covers the cube. When rendered, the quality of the 
shadows will be excellent. Now, increase the light’s cone angle to 150 
degrees so that it is covering the entire ground plane. The resulting image 
will have washed out blurry shadows. This is because the shadow map is 
being stretched over too large an area, and its resolution is not high 
enough to capture all the detail. So to fix the problem the cone angle 
must be decreased or the buffer size increased. If the buffer size is 
increased it will take up more memory, so the logical choice is to tighten 
the cone.
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The memory usage of a shadow is calculated by multiplying the pixel 
width by the pixel height to derive the total number of pixels. Then 
multiply that by 4, representing 4 bytes per pixel. And then divide that 
by 1024 to convert it into a kilobyte number.

X buffer * Y buffer * 4 / 1024

The default buffer size:

1280 * 1280 * 4 / 1024 = 6,400 Kilobytes = 6.4 Megabytes

Double the default size:

2500 * 2500 * 4 / 1024 = 25,000 Kilobytes = 25 Megabytes

As suggested before, the logical solution is to narrow the light’s cone to 
encompass only the object that will be casting the shadow. This is easy to 
do in 2.7.5.

1. Position the light and the reference roughly in the position desired.

2. While holding the Option key click on the title bar of the Camera View 
to select the shadow casting light. This will change the Camera View to 
the Light View.

3. Use the orbit, pan, etc. to more accurately position the light.

4. Open the light information window.

5. Now the cone and buffer sizes can be changed to fit the object(s) in 
view. Try to tighten the light’s cone and buffer very close to the 
boundaries of the object(s).

6. Change the Light View back to a Camera View by once again holding 
down Option, clicking in the title bar and selecting ‘Camera’.

With the ability to change both the height and width, there is no portion 
of the buffer wasted.

�
Be sure that the ‘outside of buffer area’ is disabled for parallel and radial 
lights when casting shadows. This will ensure that light casts evenly 

�
throughout the scene, while shadows remain confined to the cone region.
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Shadow Info Channels

Shadow Info channels are now available in the project window and 
animatable. Make changes as you would any other aspect of your project 
and settings will be recorded for each keyframe.
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Enable Illumination
An Enable Illumination checkbox has now been added. This checkbox, 
which defaults on, can be used to inhibit illumination for lights when 
only light-effects are desired (glows, rays, etc.). For example, if you wish 
to have the engine of a jet airplane glow bright blue and also contain a 
lensflare with obscuration, but not contaminate the surrounding engine 
duct with blue light, set up a blue glow light with the lensflare and turn 
off Enable Illumination.

Enable Illumination checkbox

Figure 8.2   Enable Illumination Checkbox
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LensFlare Plug-In
Two new checkboxes have been added to the LensFlare control window, 
“Use Light Size” and “Use Light Rotation”.

In previous versions of the plug-in, the “Light Size” edit box in the Light 
Info Window has been used to show the effective size of the lens flare’s 
Origin Glow. This Origin Glow can be considered a visible light in a 
manner similar to glow lights. Obscuration prevents the flare effect from 
being visible if the area within the Light Size is not visible to the camera. 

Version 2.7.5 improves the function of the lens flare’s Light Size by 
actually applying a distance calculation which determines the size of the 
origin glow in a given rendered frame (this is enabled using the Use Light 
Size checkbox in the LensFlare plug-in interface). If the light is moving 
away from the camera, the origin glow gets smaller in frame. If the light 
is moving closer to the camera, the origin glow gets larger in frame.

Turning on the “Use Light Size” checkbox causes the Light Size in the 
Camera Info Window to be used for both obscuration size and the lens 
flare’s glow radius. Under certain situations, this will cause difficulties. 
For example, if you want a very large glow radius, but a small obscuration 
radius (a small light bulb in a foggy room might need these settings), a 
single light size won’t work. In this case, use the Ring Size edit box in the 
LensFlare plug-in interface as a scale for the glow radius. The Light Size 
edit box in the Light Info Window will set the obscuration radius. 

For example, if you set your light’s size to 2 in the Light Info Window, 
and experience effects, you might wish to reduce the size of your light 
to.2 and then set the Ring Size in the LensFlare plug-in interface to 10 
(because the light is now ten times smaller than it was prior to the setting 
change). 
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Figure 8.3   LensFlare Dialog Box)

Use Light Size Scales the lens flare’s inner glow radius to match the lightsource’s radius 
in the vertical direction (before rotation). The outer glow radius is then 
scaled to match the inner glow radius. If the light radius is 0.0 or the “Use 
Light Size” option is disabled, the flare will appear at its default size.

Use Light Rotation Rotates the lens flare rings and spikes in 2D to match the light source 
rotation. This rotation angle is summed with the lens flare’s own rotation 
value. When the light is linked to another object, the lens flare will be 
rotated by the combination of the light and object matrices. In addition, 
the Camera’s transformation matrix (including its roll value) will affect 
the light rotation angle.
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Chapter 9 Surface Editor Changes

The Surface Editor is the dialog box used to change or modify the shading 
characteristics of any group in a model. Original comments for the 
Surface Editor can be found in the ElectricImage™ Reference Manual, 
Chapter 18. 

�
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Surface Editor Window Is Now Non-Modal
The Surface Editor is now a non-modal dialog box (it remains open while 
not selected). This makes it easier to toggle back and forth between other 
project windows and the Surface Editor.

Because it is non-modal, it will remain open even after you have made 
changes by selecting “All Keys” or “Current.” To close the Surface Editor 
Window, click on the box in the upper right hand corner of this dialogue 
box. Be sure you have selected “All Keys” or “Current” to save the 
changes you have made BEFORE closing the Surface Editor Window.

Single Characteristic Color Copy/Paste
The Material Editor now supports single characteristic color copy/paste. 

Click on the Color Preview Rectangle (the box to the left of the big 
Material Ball) to select it for copying or pasting. This gives you the ability 
to copy/paste the color from any characteristic to another characteristic 
(e.g. copy Group Color — paste to Reflectivity Color) or another group’s 
characteristic.

Figure 9.1   Color Preview Rectangle selected

�
The entire material can be copied or pasted by selecting the Material Ball to 

�
the right of the Color Preview Rectangle.
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Accessing the Surface Editor from the Project 
Window

An additional button has been placed in the toolbar and at the top of the 
project window that immediately calls up the Surface Editor. When 
activated by this button, the All Keys and Current Time buttons will set 
the material for ALL selected groups (currently highlighted in the project 
window). The title bar for the window will read: Material Of Selected 
Groups. Since the changes made using this window apply only to the 
current selected groups, the Modify in: pulldown has been removed.

The Material Of Selected Groups window effectively acts as a single-entry 
material scrapbook. When it is first opened, it will contain the material of 
the first object that is currently selected. Select other objects and press All 
Keys to apply this material to those objects.

Figure 9.2   Material of Selected Groups
ElectricImage™ Version 2.7.5 Supplement 9-3



Chapter 9: Surface Editor Changes
The traditional ElectricImage™ material window can still be 
activated as before through the material button in the Group Info 
Window. The Material Window title bar will be: (Group Name) Model 
Material when it is opened in this manner.

Figure 9.3   Model Material window
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Chapter 10 Image Display Additions

The Image Display window is utilized for previewing QuickTime movies 
and image files. Original documentation for the Image Display window 
can be found in the ElectricImage™ Version 2.5 Supplement, Chapter 6.
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Display Image / PICT Command
In the previous version there was a long delay in displaying each frame in 
an animation file.

ElectricImage™ will now index the entire movie when it is first opened. 
This allows you to navigate quickly to any frame. This approach provides 
much better access to each image of an animation without the time 
delay.

Eyedropper Tool
The Image/PICT display system has been improved in this release by 
adding an Eyedropper Tool.

The Eyedropper gives you the ability to copy the RGB channels of the 
pixel under it to the clipboard. This information can then be pasted into 
the scrapbook, or better yet, into the Surface Editor. If you hold down the 
Option Key while the mouse button is pressed, the Alpha Channel will 
also be copied. While the cursor is moved across the image, the color and 
(A)RGB values are displayed in the lower left hand corner of the image. 
The Alpha(A) value is only displayed while the Option Key is held down.

You can use this tool to copy color information from your texture maps 
into the material editor of your groups.

Figure 10.1   Eyedropper Tool
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Previewsnap Images
All previewsnap image files are now rendered into a folder called “EI 
Snapshots.” All preview images are automatically placed here for your 
reference. 

Before the application quits, all image file and PICT files located within 
the EI snapshots folder are automatically deleted. 

If you wish to make your preview snap shots permanent, go into the 
Preview/Render preferences and click the “Make Images Permanent” 
button. All snap shots then will be directed into the application folder 
not “EI Snapshots” and will not be deleted when the application quits.

Figure 10.2   Preview/Render Preference Dialog
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Chapter 11 Inverse Kinematics

The Inverse Kinematics features of ElectricImage™ have been enhanced 
through the addition of AutoIK. AutoIK implements a constraint system 
to allow Inverse Kinematic chains to be tied to objects outside their 
hierarchies.
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Introduction
Introduction
Complex inverse kinematics often requires that certain objects remain 
locked in a specific position, while moving other hierarchically related 
objects. This may be a foot sticking to the ground plane or a hand 
holding an object. AutoIK makes this easier by making an object follow 
the movement of another object.

In effect, this acts as a constraint to restrict the movement of any object 
in a hierarchy. Other objects in the chain will be forced to accept this 
restriction and will be adjusted based on the position of the constraint 
object and the other objects in the chain.

Figure 11.1   Without Auto IK

Figure 11.1 is an example of AutoIK using a hydraulic hose constrained to 
a mechanical arm. The diagrams show the result of moving the arm. In 
Figure 11.1, the arm is being moved without AutoIK applied to the hose. 
Notice that without AutoIK, the end of the hose does not attempt to 
maintain its relationship with the arm. 
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Figure 11.2   With AutoIK

Figure 11.2 shows the same movement with AutoIK constraining the 
hose to the arm. With AutoIK applied, however, the hose is forced to 
maintain the constraint’s position. If the hose is pulled farther than the 
chain can reach, it will stretch out as far as possible.

Figure 11.3   Arm Hierarchy
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Using AutoIK

Preparation

In order to use AutoIK some form of a hierarchy is needed. The hierarchy 
should already be linked and properly jointed. But the two most 
important elements are:

1. A child object to constrain. Any child, and any number of children 
may be used with AutoIK.

2. A constraint. The constraint could simply be an effector. The 
position of the constraint will determine the position of the child 
(there is no offset between the child and constraint).

�

�
Note: A child cannot be constrained to a parent or vice-versa.

AutoIK Tools

Figure 11.4   Buttons to apply and remove AutoIK Constraint

AutoIK is implemented much like the Attach, LookAt, and AutoRotate 
features. There is a button to apply AutoIK and a button to remove 
AutoIK. These can be found on the Tool Palette, in the Project Window, 
and in the Tool Menu. 
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Applying AutoIK

1. Set the time slider in the Project Window to frame 0.

2. Select the child object to constrain.

3. Press the AutoIK ‘apply’ button. 

4. Select the object to follow (the constraint object).

To cancel the process a temporary menu will appear at the top of the 
screen. Just select Terminate Operation if you don’t want to apply 
AutoIK. Choosing to cancel will not inflict any changes to the project. 
This menu will remain until the constraint group is selected.

Figure 11.5   Terminate Operation
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Specifying Termination

When using IK, the user must specify which groups in a hierarchy are 
affected. Because AutoIK does not take into account pre-selected objects 
before moving an AutoIK constraint, it must be predetermined which 
objects are to be affected. In order to do this, there is an AutoIK pulldown 
menu. This is found in the constrained object’s AutoIK channel in 
Keyframe Mode of the Project Window next to the Attach and LookAt 
channels.

To the left is the AutoIK menu for the Hydraulic Hose example. The 
constrained object is the child of ‘Link 14’, and the root parent is 
‘Fitting.’ Each consecutive object from top to bottom of the list is the 
parent of the previous. So link 14 is the child of 13 and 13 of 12, etc. 

The ‘diamond’ in the left margin of the pulldown menu represents the 
termination. This tells the AutoIK to affect all groups in the chain up to 
the ‘Fitting’ group. This means that ‘Fitting’ will not be affected and will 
remain stationary.

If ‘Self’ is specified, the group will maintain its rotation despite other 
AutoIK constraints. This is used to override AutoIK in parts of a chain 
that need more specific control.

�
Important Note: Any groups that are affected by AutoIK cannot be moved 
or rotated in any other way. Example: If the termination is set to ‘Ball,’ 
then the user would not be able to move the ‘Ball’ group or anything else in 

�
the chain, because they are all affected by the constraint.

Overlapping Constraints

Avoid overlapping constraints. An overlap is when two or more 
constraints are applied to the same groups in a chain. Any two 
constraints that affect the same groups in a chain will conflict. To avoid 
this, groups must be carefully hierarchical throughout the chain so the 
constraining objects only affect a specified portion of the chain.
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Animating AutoIK
1. AutoIK Tool 

AutoIK can be turned on and off, and reassigned to other objects 
throughout an animation. This is accomplished by using the AutoIK 
‘apply’ and ‘remove’ tools.

These buttons can be used anywhere from start to stop to reassign the 
AutoIK to another object. Wherever this is done on the time line, a 
keyframe will be created for the new assignment. In the same way, the 
‘remove’ button can be used to set a keyframe which will cause the 
constraint to ‘let go’ at that keyframe.

2. Constraint Object

One of the most powerful ways of animating an IK chain is through 
constraint objects. These objects have the ability to indirectly animate 
the IK chain by creating simple motion paths. Wherever a constraint is 
located, the IK chain will try to modify itself to match that position.

In effect, the constraint objects can be used as control handles for 
otherwise very complex IK movements. 

3. Hierarchy

The hierarchy can also be animated by using the move tool. Because the 
child will try to maintain it’s position, the hierarchy can be animated 
while the child stays in place. These types of movements occur when a 
character squats, jumps, walks, etc.

This could be combined with moving the constraint object to produce 
even more sophisticated movements.

4. Chain to Chain

Because multiple chains can be constrained to the same object, it is 
possible to virtually link multiple chains to each other. An example of 
this type of effect is seen when a person rides a bike. The crank and pedal 
would be one chain, and the leg of a character would be another chain. 
Effectors can be linked to the pedal to define foot positions for the 
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character. The characters foot could then be constrained to those 
effectors. This would cause the characters legs to bend when the bike is 
pedaled.

Tips and Techniques

Effectors

Effectors can be used to fine-tune the Auto IK alignments. AutoIK aligns 
an object to another by matching up the link points. Because this is not 
normally desired, effectors can be used as connection points.

Remember that AutoIK requires two things in order to work; a child and a 
constraint. Both can be created with effectors.

Child Effector An effector can be positioned (as crosshair) at the end of the chain 
defining the ‘connection point’ for the constraint. For a ball and chain, 
the effector would be located on the bottom of the very last link, and 
would also be the last child on the chain. The joint type of this effector 
would be ‘locked’.

Constraint Effector A duplicate of the Child Effector with a joint type of ‘free’ can be used as 
the constraint object.Using an exact duplicate of the Child for the 
Constraint will ensure that the chain is not prematurely altered and that 
the placement of the constraint is accurate. Be sure that the effector is 
first removed from the hierarchy. Furthermore, if the chain is to follow 
another chain or group, the Constraint Effector can be a child of another 
chain.
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Avoiding Joint Lock

Joint lock occurs when a joint remains straight and will not bend. Usually 
this happens in ‘pin’ joints such as a knee or elbow. When the joint is 
straight, directly applied force will not make the joint bend.

This can be fixed by adding a slight bend to the joint. To do this, reset the 
Joint Limits in the Group Link Window to numbers other than 0, 90, and 
180. A better choice might be 1, 89, and 179 degrees.

Another helpful feature in fighting joint lock is viscosity, also set in the 
Group Link Window. Viscosity will make joints more resistant to 
movement. Joints with less viscosity are more likely to bend. For a 
human character, the knee and elbow joints should be given a low 
amount of viscosity, such as ‘0’, while the wrist and shoulder may have a 
viscosity of ‘100’. This will make the knee and elbow joints more willing 
to bend.

Tilt and Rotation

When using AutoIK, constrained objects will have a tendency to tilt. 
With an animation such as a walk cycle, it is important that the feet lay 
flat on the ground with each step taken.

To correct this there is an option on the Kinematics Palette to “Keep 
World Orientation.” When turning this option on, the last object on the 
chain will not only match the position on the constraint, but will also 
match rotation. So with a walk cycle, the rotation of the foot can be 
controlled by simply rotating the constraint object or effector.
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Controlling Updates

AutoIK is based on custom frames like the Attach, LookAt and AutoRotate 
features. A custom frame is animation data that is independent of 
keyframes and individual to each frame. A custom frame value will 
override keyframe interpolation. When the Project Window is in 
Keyframe Mode a custom frame is denoted by an underline, but is not 
visible in time mode. Tools that create custom frames are: AutoRotate, 
Attach, LookAt, Spring, Jolt, Randomize, Fill, Blend and all Repeats.

ElectricImage™ must recalculate the custom frames whenever a change is 
made. The amount of processing time it takes for recalculation depends 
on the number of frames there are in the animation. Recalculation time 
may pose an inconvenience. If it does, there is a preference to turn off the 
auto-calculate and allow the user to manually calculate AutoIK. 

Figure 11.6   Compute Automatically Preference

To do this, select ‘Keyframe’ from the Edit Menu. At the bottom of the 
Keyframe Preferences is a check box. If this is turned off, AutoIK will not 
recalculate until the user forces an update. 

An update is forced by pressing Command + U, or selecting ‘Calculate 
Auto Frames’ from the Keyframe Menu. 
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Removing AutoIK

Because AutoIK uses custom frames, there are several precautions to take 
when removing AutoIK.

1. Move the time marker to ‘0’ before removing AutoIK. This will 
ensure that the hierarchy is not left posed at some arbitrary point in 
the animation.

2. Select the object(s) to remove AutoIK from.

3. Next, press the AutoIK ‘remove’ button from the Tool Palette or at 
the top-right corner of the Project Window. This will cause the 
AutoIK channel to change to ‘none’ for all frames.

4. Select Clear All Keyframes from the Keyframe Menu. This will 
delete all of the keyframes ensuring that no AutoIK keyframes 
remain.

5. Because AutoIK is based on custom frames, custom frames will be 
generated in the rotation and position channels of all objects 
affected. Removing the AutoIK from the constrained object will not 
remove custom frames. This will cause a ghosting effect to occur 
where the custom frames from the last calculation are still present in 
the animation. To clear the custom frames, select the objects to 
reset, hold down the Shift key, and then select Recalculate All 
Frames from the Keyframe Menu. This will recalculate frames for 
the selected objects only, clearing all custom data.
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Troubleshooting AutoIK
Object is not

remaining locked to
constraint object.

1. Turn off Global Gravity on the Kinematics Palette and Local 
Gravity in the Group Link Window. This causes the constrained 
object to lag and not always connect with the constraint object 
correctly.

2. AutoIK will do it’s best to maintain the child’s position, but if the 
problem is simply that the chain cannot reach, then there is little 
that can be done. AutoIK will not break the constraints of the chain, 
so in order to maintain a connection either the chain or the 
constraint object must be moved.

3. Check the link positions of the child and the constraint in the 
working windows. If the links are in the same position, then it is 
working correctly and will likely need some adjustment from the 
Group Link Window.

4. Check the constraints termination. If the constraint overlaps and 
interferes with another constraint, then the hierarchy must be 
reorganized or the termination levels must be reset.

Long Calculating
Times

1. The calculation can be turned off to allow the user control.

2. The stop time can be changed to shorten the length of the 
animation. This can be a temporary change until rendering the final 
animation. Do not change the start time. This will disrupt all custom 
frames and may destroy some of the animation in the project.

Constraint Error “Can’t constrain to effector because it creates circular hierarchical 
relationships”

This error message results when a parent object is linked to a child. This 
will also occur with AutoIK any time a child is constrained to a parent. 
This error occurs when circular hierarchies cannot be created. 

Object is not Remaining Locked to Constraint Object
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Make sure to “Keep Object Orientation” on, if the object is to follow the 
rotation of the constraint. If “Keep World Orientation” is off, then only 
the position of the object is met.
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Chapter 12 QuickTime and QTVR
Rendering Features

The renderer, Camera, supports rendering to any QuickTime CODEC 
(hardware or software), rendering to the PICT file format, rendering to 
QTVR Panorama, or rendering to a warped Image or warped PICT file.

�
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QuickTime and PICT Support
The Format pulldown now lets you set the output rendering to Image, 
QuickTime or PICT files. If PICT is chosen and there is more than one 
frame to be rendered, Camera will output a series of numbered PICT files.

Choosing either QuickTime or PICT brings up a window that lets you 
choose a hardware or software compression CODEC. 

�
Please remember that the CODEC must be present on any slave machines 

�
that will be used to render the animation.

The CODEC window also lets you override the bits per pixel and frames 
per second settings that you chose in the Render Control Window.

Format Pulldown QTVR Enable Checkbox

Figure 12.1   Render Control Window
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QuickTimeVR Panorama 
Version 2.7.5 allows you to render directly to a finished QTVR panorama, 
to a warped PICT, or to a warped Image file. The VR Enable checkbox in 
the Render Control Window turns on the QTVR system. The Format 
pulldown in the Render Control Window controls the output file format 
(QTVR – QuickTime, warped PICT – PICT, or warped Image– Image).

Warped PICT files are used with multimedia authoring tools because 
many do not accept QTVR movies directly. The process of adding nodes is 
done with warped PICT files.

QTVR has several rules regarding output resolutions. The X dimension 
must be evenly divisible by 96 and the Y dimension evenly divisible by 4. 
Common output resolutions include: 2496 by 768 and 1248 by 384.

Camera renders the QTVR in four panes, each with a 90 degree horizontal 
field-of-view (FOV). Make sure that the horizontal FOV is set to 90 
degrees in the Camera Info Window. One of these panes will be displayed 
in the Camera View Window when QTVR is enabled. Once the horizontal 
FOV has been set to 90 degrees, the vertical FOV will automatically reflect 
the proper value for the output warped file or QTVR.

During render time, all four views will be automatically rendered, rotated 
and properly warped. If QuickTime has been selected as the format in the 
Render Control Window, the output image will be diced and compressed 
into a QTVR using the chosen CODEC.
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Chapter 13 Camera Map Projection Plug-In
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Chapter 13: Camera Map Projection Plug-In
Introduction
Camera Map Projection is the ability to project a flat texture map from an 
arbitrary angle across multiple model groups. If you were to view the 
scene from the same point in space from which the map is projected, the 
scene would look exactly like the image you are mapping. If viewed from 
a differing angle, however, the scene appears to have a new depth and 
perspective. This phenomenon can be used to make a photo or painting 
appear as if it really exists in three dimensions.

Figure 13.1   CameraMap Icon From The Object Palette

There are a few requirements to consider:

First, the model geometry that is receiving the projection map must 
somehow approximate the visual content of the map. For example, if you 
were using a photograph of some downtown high rises, you would need 
to create some simple geometry that would approximate the major 
shapes in the photo. You will also want to include a background plane, 
and a floor plane as well, to catch the non-modeled components of the 
photo.

Second, you can move off axis, and in and out of the original framing of 
the photo, within reason. At some point, the effect will become visible 
for what it is, ruining your shot. Trial and error define these parameters, 
as each shot is different. You can push this effect very far, however.

Third, you will typically want to make groups receiving the Camera Map 
Projection 100% luminant. This will keep Camera from applying any 
shading to the groups - all shading will be provided by the map. Failure 
to do so will result in additional shading, which may result in unwanted 
effects (this is up to you.)

Fourth, the map should be somewhat larger than the resolution which 
you are rendering to, as this gives you more leeway in moving the camera 
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within the shot. If the map is large enough, you can push in quite a ways 
before interpolation begins to take place, giving away the effect.

�
For sharper maps, you can deactivate the map smoothing feature by setting 
the softness popup in the group’s Texture Map Window to “none.” Aliasing 
will increase slightly, but may not be objectionable if using Oversample 
image anti-aliasing, or by setting the sample rates of the groups receiving 
the Camera Map Projection to 8x8 or higher (this will lengthen your 

�
rendering time, of course.)
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When To Use Camera Map Projection
Use this technique when you need to create an environment quickly, but 
don’t have the time (or the memory) to build complex models to achieve 
the effect you are going after. You can, for example, create an ancient 
Egyptian city with a high degree of detail by the following method:

First, create a city out of simple shapes, like cuboids, cylinders and 
pyramids. Create a ground plane and sky backdrop, either as a plane, or 
as a cyclorama (a sheet which surrounds the city, which may or may not 
be curved at the bottom).

Next, render a good angle for a painting. Setup your lighting to 
approximate the lighting in the final shot. This rendering will be used to 
paint the actual map. Please be sure to note the location of the camera, in 
both position, rotation and focal length, as this information is necessary 
for the Camera Map Projection to work properly.

Now comes the hard part. Load the rendering into Photoshop or Painter, 
and paint on top of the rendering, making the scene appear as you would 
like (Hopefully, you are a good artist!) You may wish to create elements 
on different layers, such as a separate sky and ground plane. Isolating 
elements like this can give you a little more freedom of camera 
movement later, as these elements can be applied separately in 
ElectricImage™.

After you have finished the painting to your satisfaction, you then must 
go back to ElectricImage. In the same project, add the CameraMap 
plug-in. Parent the groups that were used to create the simple city to the 
plug-in (the groups are now children of the plug-in). Set the luminance 
attribute of the groups to 100% (that’s the far left slider bar in the 
Material Editor.) Now, add the painting that you created as a texture map 
to the CameraMap group. Lastly, copy the information from the original 
camera position into the Camera Map plug-in via the options button in 
the CameraMap’s option window.
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Figure 13.2   CameraMap Dialog Box

Render the scene. It should look identical to your painting (allowing for 
image filtering.) Now, create an animation with the camera itself (not the 
CameraMap!) moving off axis, either inwards or around the scene. 
Render and watch the result. If everything went well, you should see a 
fantastic dimensional vista coming to life! At some point in the movie, 
the effect may show itself, in the form of some stretching distortion. 
Should that occur, you have just observed the limits of how far you can 
push the effect for this particular shot.

An alternative approach would be to work with an existing photograph 
or painting. This requires more planning, as you must align your models 
and camera to match the perspective of the original shot. It’s not too 
hard (hey, we did it for Terminator 2!) but can be tedious. Once you have 
done it a couple of times, its not so bad.
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Benefits Of Camera Map Projection
Traditionally in special visual effects, the matte painting has been a great 
tool in adding scope, establishing a location or time, but has always 
suffered the curse of being flat. Over the years, creative artists like Albert 
Whitlock, Peter and Harrison Ellenshaw, and many others have added 
lateral camera movement, foreground models and various optical effects 
to hide the painted nature of the shot. This worked for decades, but never 
really fooled the sophisticated viewer. When Star Wars entered our 
lexicon, the fascination with the creation of visual effects prompted 
many different outlets of technical information. That information led to 
the public exposure of many “tricks of the trade”, matte paintings among 
them. Until the advent of computer graphic effects, it was difficult to 
make the matte paintings more realistic.

Camera Map Projection can change all of that. As illustrated previously, a 
painting can now appear to exist in three dimensions (within reason!) 
and again allow for the suspension of disbelief that is so necessary when 
creating special visual effects.

On the technical 3D rendering side, Camera Map Projections offers many 
benefits:

Far fewer individual texture maps. As one map can be used across 
many groups, the amount of maps needed is reduced.

Lower resolution maps. Even though the scene is viewed in perspective, 
the texture map is kept aligned with the film plane of the synthetic 
camera (within reason.) This allows far less scaling of individual pixels in 
the map, and requires far less pixels in the overall map. Because 
distortion is kept to a minimum, the simple flat projection works very 
well. The relationship of texture map pixels to screen pixels is much 
closer to 1:1 than any other mapping style. Simply put, you get more for 
less.

More complexity for less modeling. Traditionally, it has always been 
easier to paint a picture than to build a model. This is especially true with 
many of the computer modeling programs available today. A simple 
stroke of the brush is just that in a painting, but the same thing 
translated to a model can cost thousand of polygons. With Camera Map 
Projection, you get the best of both worlds.
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Drawbacks of Camera Map Projection
Unfortunately, there are a few (but only a few!) The first one is one that 
you have already encountered: You do have a limited range of 
movement.

Memory is also a consideration. Although you are saving large amounts 
of memory by making the textures more efficient, CameraMap plug-in 
needs to load all attached groups into memory at once in order to work. 
That means that more memory is required to render models with a large 
number of polygons. Once you get a feel for it, however, you should be 
fine.

�
For groups linked to the CameraMap plug-in, break up large polygons into 
smaller ones. This will increase the distance that the Camera can be moved 
before the effect begins to break down. A large polygon is one which takes up 

�
more than about 1/8th of the screen.

Uses of Camera Map Projection
Multiple CameraMap plug-ins can be used in a single scene. As the 
perspective of the original painting is fixed, a final shot may be larger in 
scope than the painting can convey. Using multiple Camera Maps can 
solve this dilemma. Also, a particular effect may not require one full 
screen resolution Camera Map, but rather many small ones.

When using a “sky plane” in the background of an interior shot (looking 
out of a window), the Camera Map Projection can add much more 
realism to this typically flat look. And, because the window allows only a 
small portion of the overall map to be seen, you can push the effect much 
farther.

Mixing regular models and Camera Mapped models together often results 
in the most realistic shot. The effect is virtually impossible to detect when 
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there are other components in the scene which help to disguise it. These 
same components can also help to blend multiple camera maps together.
13-8 ElectricImage™



Chapter 14 Value Modification
ElectricImage™ Version 2.7.5 Supplement



ElectricImage™ 



Chapter 14 Value Modification System 
Additions

A simple system to enter percentage and relative numerical value changes 
to the Project Window cells, and the edit boxes of most modal and 
non-modal windows was added in Version 2.5. Original comments for 
the Value Modification System can be found in the ElectricImage™ 
Version 2.5 Supplement, Chapter 11. Two new symbols have been added.

�
Contents

Additions to the Value Modification System ...........................14-2
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Additions to the Value Modification System 
For Version 2.7.5 we have added two new symbols:

! converts the current cell to the opposite (positive or negative) value.

#  returns the absolute value of the current cell or the entire channel.

Usage Examples:

Original 
Value

Formula
 Returns the 

Value

5.0 @! -5.0

-5.0 @! 5.0

0.0 @! 0.0

-5.0 @# 5.0

5.0 @# 5.0

0.0 @# 0.0
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All Symbols that are currently supported:

Symbol Action

! Pos/Neg 
function

# Absolute
value

+ Add

- Subtract

* Multiply

/ Divide

^ Exponential 
(to the 

power of…)

% Percentage
ElectricImage™ Version 2.7.5 Supplement 14-3



Chapter 14: Value Modification System Additions
14-4 ElectricImage™



Chapter 15 Motion Data Import/Export
ElectricImage™ Version 2.7.5 Supplement



ElectricImage™ 



Chapter 15 Motion Data Import/Export*

ElectricImage™ Animation System supports importing and exporting 
motion capture data. This feature is optional for ElectricImage Broadcast 
users (for more information please contact sales or customer service.). 
Three different formats are supported. All data is read in as custom 
keyframes.

�
Contents

Motion Capture Data...................................................................15-2

.bvh.................................................................................................15-2

.bva .................................................................................................15-2

.obm ...............................................................................................15-2

Using the Motion Data Import Feature ....................................15-3

Using the Motion Data Export Feature.....................................15-4

*Motion Data Capture is a feature of the ElectricImage Animation System. 
This feature is available to ElectricImage Broadcast users as an option. Please 
contact sales or customer service for more information.
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Motion Capture Data
Electricimage™ now imports and exports motion capture data from three 
different file formats. These three formats include the group names for 
the models that will receive the motion data in their file headers. If 
matching groups are found in your project during motion capture 
importation, the data will be added to those groups. If not, 
ElectricImage™ will offer you the opportunity to create a model using a 
new form of effector, the skeleton effector.

.bvh

The BioVision Hierarchical format, .bvh, is the preferred format for 
motion data importation. It includes a header that accurately describes 
the model hierarchy. By using this format you insure that the lengths of 
the links between groups will be taken into account when the data is 
imported.

.bva

The BioVision Flat format, .bva, should only be used for groups that are 
not in a hierarchy. 

Information on the BioVision formats along with sample data can be 
found at http://www.biovision.com or directly from BioVision, Inc. 1590 
California St. San Francisco, CA 94109 415-292-0333

.obm

The ElectricImage™ Motion format, .obm, is designed to exchange 
camera motion data between different animation programs or between 
ElectricImage™ and a motion control system. This format can accept 
group names with spaces in them. The .bva and.bvh formats do not.
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Using the Motion Data Import Feature

The Motion Data import feature is available through the File Menu >Add 
>Motion Data... submenu. There is no need to select (highlight) groups 
before issuing the command. ElectricImage™ compares the group names 
in the header of the motion data file to those in the project file and adds 
the data to the matching groups.

Figure 15.1   Motion import dialogue

Offset Filter Adds an offset to the position data during importation.

Rotation Filter Adds an offset to the rotation data during importation.

Motion Samples:
Time

Duration of each sample (one over the number of samples per second).

Motion Samples:
Total

Number of samples present in the motion capture file.

Start Controls which sample to begin with when data is imported.

Fix Rotation Order Enables a change in the rotation order, either the groups rotation order or 
the rotation order of the motion data.

Change Rotation
Order

Changes the rotation order of the groups to force them to conform to the 
rotation order in the capture file.

Process Motion Data Changes the rotation order in the capture file to conform to the current 
groups’ rotation order.
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Using the Motion Data Export Feature

The Motion Data Export feature is available through the File Menu 
>Export >Motion submenus. Select (highlight) the groups you wish to 
export motion from before issuing the command. 

Figure 15.2   Motion export dialogue

Selected with
Children

Motion data is written out for selected groups and all groups linked to 
them.

Selected Only Motion data is written out for selected groups only.

Frame Range Selects the range of frames for which motion data is written out.

Output
carriage-return/line-

feed to end a line

Alternate line termination for systems requiring CR/LF.

Use Objects Rotation
Order

Uses the rotation order of each object when writing out the file. The 
default is to use YXZ as the rotation order for all groups

Reference Rotations
are exported as

Objects with references (cameras and spotlights) are exported using 
specified rotation order.
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Appendix A Keyboard/Mouse Commands

This Appendix contains all of the Keyboard and Mouse commands 
available in ElectricImage™. This appendix replaces Appendix E in the 
original Reference Manual.

Conventions ....................................................................................A-3

World View Window Controls......................................................A-4

Camera View Window Controls ...................................................A-5

Project Window Controls..............................................................A-5

QuickTime Window Controls........................................................A-6

Velocity Window Controls ............................................................A-7

Light Info Window Controls.........................................................A-7

Group Info Window Controls .......................................................A-8

Group Link Window Controls.......................................................A-8

Group Texture Window Controls...............................................A-10

Tool and Object Palette Controls...............................................A-11

Render Control Window Controls .............................................A-11
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File Menu Controls....................................................................... A-11

Edit Menu Controls ...................................................................... A-12

Keyframe Menu Controls ............................................................ A-12

Select Menu Controls .................................................................. A-13

Windows Menu Controls ............................................................ A-13

Tools Menu Controls.................................................................... A-14

Special Controls............................................................................ A-14
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Conventions
Conventions

Keyboard Symbols

The following symbols are used to represent specific keys:

Command key

Option key

Control key

Shift key

Using the Tables

To achieve the desired result as listed in the right column, press the key(s) 
shown in the left column while performing the mouse action described 
in the middle column (if any). When two or more keys are shown, hold 
down the keys simultaneously.
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World View Window
Controls

Figure A.1 lists keyboard/mouse actions available for use in the World 
View windows

Figure A.1   World View window keyboard/mouse controls

Press Key(s) + Mouse Action Result

Click zoom button. Fit world size into window.

Click Zoom Window tool. Zoom out.

Click Zoom Button Fits all selected objects into the window.

Click and drag a rectangle. Zoom to selected area.

Spacebar Click and drag in window. Drag the window’s view.

Click and drag object part Rotate object using best rotation for the view.

Click and drag object part. Rotate object on X axis.

Click and drag object part. Rotate object on Y axis.

Click and drag object part. Rotate object on Z axis.

Click and drag group center. Drag group center.

Arrow key Move selection in frontmost window by 1 pixel.

Arrow key Move selection in frontmost window by 10 pixels.

Click Shading button. Open pop-up menu for drawing preferences.

Click Preview button. Open pop-up menu for preview preferences.

Double-click group. Open Group Texture window for group.

Double-click group. Open Group Link window for group.

Double-click group. Open Group Deformation window for group.

Double-click light. Select light color.

Click in title bar. Select new projection.

Click and drag Bezier handle. Dolly the handle.

Click and drag Bezier handle. Realign handles to create continuous curve.

Click and drag Bezier handle. Break handles to create non-continuous curve.
A-4 ElectricImage™



Conventions
Camera View
Window Controls

Figure A.2 lists keyboard/mouse actions available for use in the Camera 
View window.

Project Window
Controls

Figure A.3 lists keyboard/mouse actions available for use in the Project 
window.

Figure A.2   Camera View window keyboard/mouse controls

Press Key(s) + Mouse Action Result

Click Shading button. Open pop-up menu for drawing preferences.

Click Preview button. Open pop-up menu for preview preferences.

Click Fieldchart button. Open pop-up menu for fieldchart preferences.

Spacebar Click and drag in Camera Window. Track the Camera or Light.

 Spacebar Click and drag in Camera Window. Orbit the Camera or Light.

 Spacebar Click and drag in Camera Window. Pan the Camera or Light.

 Spacebar Click and drag in Camera Window. Dolly the Camera or Light.

 Spacebar Click and drag in Camera Window. Zoom the Camera.

Click in the title bar Pull down view object menu (Camera and shadow 
lights).

Figure A.3   Project window keyboard/mouse controls

Press Key(s) + Mouse Action Result

Click zoom button in Time mode. Fit timing size into window.

Click flags in status panel
(flat view).

Set elements down the list in the same class to the 
toggled value.

Click flags in status panel 
(hierarchical view).

Set children to the toggled value.

Double-click soundtrack icon. Play/stop selected soundtrack.
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QuickTime Window
Controls

Figure A.4 lists keyboard/mouse actions available for use in the 
QuickTime display window.

Double-click group. Open Group Texture window for group.

Double-click group. Open Group Link window for group.

Double-click group. Open Group Deformation window for group.

Click in data cell. Select all data cells in row.

Click in data cell. Select row and columns fro last selection to new 
selection.

 Click in data cell. Include/exclude whole row(s) in the selection.

Up Arrow Click in data cell. Include/exclude row above.

Down 
Arrow 

Click in data cell. Include/exclude row below.

Left 
Arrow 

Click in data cell. Include/exclude column to the left.

Right 
Arrow 

Click in data cell. Include/exclude column to the right.

Click and drag in the time line. Select keyframe time scaling region.

Click and drag selected keyframes. Interactive keyframe time scaling.

Click individual keyframes. Select multiple keyframes for dragging or scaling.

Click and drag time thumb. Drag time thumb while displaying time code.

Click and drag sound track lines. Include/exclude cue time duration.

Clicking visibility or lock boxes. Set all objects following to new state.

Figure A.3   Project window keyboard/mouse controls

Press Key(s) + Mouse Action Result

Figure A.4   QuickTime window keyboard/mouse controls

Press Key(s) + Mouse Action Result

Click in title bar. Select new QuickTime option.
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Velocity Window
Controls

Figure A.5 lists keyboard/mouse actions available for use in the Velocity 
windows.

Light Info Window
Controls

Figure A.6 lists keyboard/mouse actions available for use in the Light Info 
window.

Figure A.5   Velocity window keyboard/mouse controls

Press Key(s) + Mouse Action Result

Click zoom button. Fit velocity size into window.

Click zoom out button. Shrink velocity graph size.

Click zoom in button. Expand velocity graph size.

Click and drag on keyframe bar. Drag without snap to frame.

Click and drag intersection of 
keyframe and teeter bars.

Drag time and velocity.

Figure A.6   Light Info window keyboard/mouse controls

Press Key(s) + Mouse Action Result

Click button/pop-up. Set all lights to value.

Click button/pop-up. Set remaining lights to value.

Click button/pop-up. Set all children to value.

Click button/pop-up. Set immediate children to value.
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Group Info Window
Controls

Figure A.7 lists keyboard/mouse actions available for use in the Group 
Info window.

Group Link Window
Controls

Figure A.8 lists keyboard/mouse actions available for use in the Group 
Link window.

Figure A.7   Group Info window keyboard/mouse controls

Press Key(s) + Mouse Action Result

Click button/pop-up. Set all groups to value.

Click button/pop-up. Set remaining groups to value.

Click button/pop-up. Set all children to value.

Click button/pop-up. Set immediate children to value.

Click material’s preview ball. Select background color for shading ball

Click material’s preview ball. Select background color for shading ball

Click material’s preview color field. Select color using the Macintosh color picker

Click material’s preview color field. Select color using the Macintosh color picker

Figure A.8   Group Link window keyboard/mouse controls

Press Key(s) + Mouse Action Result

Click and drag gnome. Rotate Z axis.

Click and drag gnome. Rotate Y axis.

Click and drag gnome. Rotate X axis.

Click zoom button. Fit world size into window.

Click Zoom Window tool. Zoom out.

Click and drag rectangle. Zoom to selected area.

Click in content. Create new selection area if in texture.

Click button/pop-up. Set all groups to value.

Click button/pop-up. Set remaining groups to value.
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Click button/pop-up. Set all children to value.

Click button/pop-up. Set immediate children to value.

Figure A.8   Group Link window keyboard/mouse controls

Press Key(s) + Mouse Action Result
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Group Texture
Window Controls

Figure A.9 lists keyboard/mouse actions available for use in the Group 
Texture window.

Figure A.9   Group Texture window keyboard/mouse controls

Press Key(s) + Mouse Action Result

Click and drag gnome. Rotate Z axis.

Click and drag gnome. Rotate Y axis.

Click and drag gnome. Rotate X axis.

Click zoom button. Fit world size into window.

Click Zoom Window tool. Zoom out.

Click and drag rectangle. Zoom to selected area.

Click in content. Create new selection area if in texture.

Click button/pop-up. Set all groups to value.

Click button/pop-up. Set remaining groups to value.

Click button/pop-up. Set all children to value.

Click button/pop-up. Set immediate children to value.
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Tool and Object
Palette Controls

Figure A.10 lists keyboard/mouse actions available for use in the Tool and 
Object Palettes.

Render Control
Window Controls

Figure A.11 lists keyboard/mouse actions available for use in the Render 
Control Window.

File Menu Controls Figure A.12 lists keyboard/mouse actions available for use with the File 
menu.

Figure A.10   Palette keyboard/mouse controls

Press Key(s) + Mouse Action Result

Click Translation icon. Show custom drag angle when in custom drag mode.

Click Deformations tool. Toggle deform enable bit.

Click a plug-in icon. Show plug-in information.

Click Unlink icon. Reset prerotations when unlinking.

Figure A.11   Render Control window keyboard/mouse controls

Press Key(s) + Mouse Action Result

Click Go. Select remote camera (EI will not shut down).

Click Go. Automatically save the project before launching 
Camera.

Figure A.12   File menu keyboard/mouse controls

Press Key(s) + Mouse Action Result

Choose Add > Plug-in. Show plug-in information.

Choose Group Info. Open Group Texture window for selected group.

Choose Group Info. Open Group Link window for selected group.

Choose Group Info. Open Group Deformation window for selected group.

Choose Group Info. Show Plug-in interface dialog if available.

Choose Light Info. Select light color.
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Edit Menu Controls Figure A.13 lists keyboard/mouse actions available for use with the Edit 
menu.

Keyframe Menu
Controls

Figure A.14 lists keyboard/mouse actions available for use with the 
Keyframe menu.

Choose Light Info. Show Link window for the selected light.

Choose Camera Info. Show Link window for the camera.

Choose Effector Info. Show Link window for the selected Effector.

Choose Smoker Info. Show Link window for the selected Smoker.

Choose Sound Info. Play/stop selected soundtrack.

Choose Projector. Launch Projector without exiting ElectricImage™.

Choose Save. Saves project without asking permission to override.

Choose Export submenu item. Saves a model for every frame in the animation.

Choose Alphabet button in Mr. 
Font.

Brings in 255 characters as sample.

Figure A.12   File menu keyboard/mouse controls

Press Key(s) + Mouse Action Result

Figure A.13   Edit menu keyboard/mouse controls

Press Key(s) + Mouse Action Result

Choose Default Preferences. Reset window defaults only.

C --- Select Special Copy

Figure A.14   Keyframe menu keyboard/mouse controls

Press Key(s) + Mouse Action Result

Select Recalculate All Frames Recalculates frames for selected groups

--- Changes Calculate Autoframes selection into Force to 
Calculate Autoframes.
A-12 ElectricImage™



Conventions
Select Menu Controls Figure A.15 lists keyboard/mouse actions available for use with the Select 
menu.

Windows Menu
Controls

Figure A.16 lists keyboard/mouse actions available for use with the 
Windows menu.

Figure A.15   Select menu keyboard/mouse controls

Press Key(s) + Mouse Action Result

Choose All. Selects all objects including the locked ones.

Choose Select by 
Hierarchy>Parent.

Selects all ancestors.

Choose Select by 
Hierarchy>Children.

Selects all offspring.

Figure A.16   Windows menu keyboard/mouse controls

Press Key(s) + Mouse Action Result

Choose Top View. Reset Top View window to default position and size.

Choose Front View. Reset Front View window to default position and size.

Choose Side View. Reset Side View window to default position and size.

Choose Camera View. Reset Camera View window to default position and 
size.

Choose Project. Reset Project window to default position and size.

Choose Model Velocity. Reset velocity window to default position and size.

Choose Camera Velocity. Reset velocity window to default position and size.

Choose Light Velocity. Reset velocity window to default position and size.
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Tools Menu Controls Figure A.17 lists keyboard/mouse actions available for use in the Tool 
Menu and Tool Palette.

Special Controls Figure A.18 lists keyboard/mouse actions available for use in certain 
specific situations.

Figure A.17   Tools menu controls

Press Key(s) + Mouse Action Result

Choose Translation. Show custom drag angle when in custom drag mode.

Choose Deformations. Globally disable any deformations.

Choose Unlink from Parent. Reset prerotations when unlinking.

Choose remove Autorotation Removes all autorotate intervals

Choose remove AutoIK Constraint Remove all constraint intervals

Figure A.18   Special controls

Press Key(s) + Mouse Action Result

. --- Exit ElectricImage™ while application is loading.

Q --- Exit ElectricImage™ while application is loading.

1 --- Select top view of frontmost World View window.

2 --- Select side view of frontmost World View window.

3 --- Select front view of frontmost World View window.

[ --- Zoom in on frontmost World View window.

] --- Zoom out of frontmost World View window.

= --- Fit to window frontmost World View window.

H --- Toggle hide children flag of selected objects.

Caps Lock --- Lock dragging to grid values.

Tab --- Shift translation cursor from 
none-horizontal-vertical-user defined and back again.

Home --- Fit world content into window view.
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 Page-Up --- Page rather than scroll the drawing windows.

 Page-Down --- Page rather than scroll the drawing windows.

While dragging end of chain with 
IK tool.

Interactively changes the third axis not available from 
the current window projection (front-z, side-x, top-y).

Figure A.18   Special controls

Press Key(s) + Mouse Action Result
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Index
Symbols
! 14-2
# 14-2
.bva 15-2
.bvh 15-2
.OBJ 7-2

Numerics
3DMF

adaptive tesselation 7-3
fixed tesselation 7-3
preference 7-2
tesselation 7-3

3DMF binary 7-2

A
Absolute Value 14-2
All Keys 2-4
Attach 11-5
Auto-calculate 11-11
AutoIK 11-3

animating 11-8
constraint 11-7
effectors 11-9
hierarchy 11-5, 11-7
joint Limits 11-10
joint Lock 11-10
Local Gravity 11-13
removing 11-12

terminate operation 11-6
termination 11-7
tool menu 11-5
tool palette 11-5
updates 11-11

AutoRotate 11-5

C
Camera 4-6, 4-7, 12-1
Camera Map Projection 13-2
CameraMap

limits 13-5
luminance attribute 13-4
multiple 13-7
option window 13-4
softness popup 13-3

CODEC 12-1
Color Labels 2-2, 2-7

Edit... 2-7
Constraint 11-3, 11-5
Constraint Error 11-13
Current Time 2-4
Curvature 7-3
Custom Frame 11-11, 11-12

D
Drawing Preference Window 2-3
ment IX-1



E
Edit bar 2-5
Effectors 11-5
Enable Illumination 8-6
Enter key 2-2
Eyedropper 10-2

alpha channel 10-2
clipboard 10-2
scrapbook 10-2

F
Focal Length 4-3
FOV 12-3
Frame Index Start 2-3
Frames 2-5

G
Global Gravity 11-13

I
Image 12-3
Image Display 10-1
Interlace 2-6
Inverse Kinematics 11-3

J
Jog 3-2

K
Keyframe

animation track 2-11
dragging 2-10
duplication 2-13
Selection 2-10

Kinematics Palette 11-13

L
LensFlare

use light rotation 8-7
use light size 8-7

Lensflare 8-6
LensFlare Plug-In 8-7
Light

yaw, pitch and roll 8-2
Light Info Window 8-1
Locking 2-2
LookAt 11-5
Luminant 13-2

M
Material Of Selected Groups 9-3
Model Import/Export

3DMF 7-2
Wavefront .OBJ 7-2

Model Material 9-4
motion capture 15-1
Move controls 4-2

dolly 4-2
none 4-2
orbit 4-2
pan 4-2
track 4-2
zoom 4-3

MPCamera 4-7
Multiple Keyframe Control 2-10
multiprocessor 4-7

N
Normals 7-2

O
Overlapping Constraints 11-7

P
PICT 12-1, 12-2, 12-3
Preview/Render Preferences 10-3
Previewsnap 4-2
Project Window 2-1, 11-11

edit box 2-2
enter key 2-2

Q
QTVR 12-3
QuickTime 12-1, 12-2
QuickTimeVR 12-3

S
Scaling region 2-11
Seconds 2-5
Select Menu 5-1, 6-1
Shadow 8-3

buffer 8-3
color 8-3
info channels 8-5

Smoke objects 8-2
SMP 4-7
Surface Editor 2-2, 2-4, 9-1

all keys 9-3
copy and paste 9-2
current time 9-3

T
Time line 2-11
Time Thumb Control 2-2, 2-5
Timecode 2-5

V
Value Modification System 14-1

! 14-2
# 14-2
absolute value 14-2

Velocity curve 4-3
View By Hierarchy 2-2, 2-8

by label 2-9
by Name 2-9
flat 2-8
hierarchy 2-8

Viscosity 11-10
Visible 2-2

W
warped 12-1, 12-3
World View Windows 3-1

Z
Zoom 3-3
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